0 votes
asked in VRIK by (140 points)
edited by
Hi-- I've been tinkering with VRIK for about a day now. I followed the YouTube setup tutorial to the letter but cannot get VRIK to work with any character model that isn't the default pilot model from the sample scenes. Other models simply don't respond to movement. I get no showstopping errors during runtime.

I've played with nearly every setting. I tried configuring the VRIK script in different ways: head/hands only, entire skeleton, dozens of other combinations... nothing works. My impression is that this should be pretty plug-and-play so I assume I'm missing something simple/obvious but can't determine what it might be.

I'm using Unity 2017.3 with the Oculus SDK. All required Oculus plugins are in the project (Platform SDK, Avatar SDK, Unity Utilities) and otherwise work fine. I've tried a couple models from Mixamo and a couple purchased from Turbosquid. They're all rigged correctly and otherwise work with the Unity animation system.

Any ideas? What information/screens can I provide that would help troubleshoot? Thank you!

1 Answer

0 votes
answered by (8.5k points)
Hey,

Could you give me a screenshot of the VRIK component's References expanded? Also, could send me a package with one of these characters set up to support@root-motion.com, so I could take a closer look.

Best,

Pärtel
commented by
Hi Partel,

I am having the same issue as well, I cant use the characters I made in blender but i can use the example pilot the asset came with. Do you mind if I emal you as well?

Thanks
commented by (8.5k points)
Hey,

Please do, attach the fbx if possible so I could take a closer look.

Best,

Pärtel

Welcome to RootMotion Q&A, where you can ask questions and receive answers from the developer of Final IK and PuppetMaster and other members of the community.

Post as a guest, create an account or login via Facebook.

Please use the correct category when you post your questions.

...